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1. PREFACE

This manual will guide you through the installation and operation of the uPD78 Dashboard
Programmer, referenced hereafter as the uPD78-Programmer.

The uPD78-Programmer has been designed for Reading, Programming of EEPROM
contents of the next NEC Microcontroller Unit (MCU):

v uPD780973
v uPD780949
v uPD78F0949
v uPD78F0828A M1

(?

Note: Devices that not mentioned above in list can’t be guaranteed of correct
reading, programming by uPD78-Programmer.

2. CHECKLIST AND REQUIREMENTS

The following describes what items are supplied with the uPD78-Programmer:
v uPD78-Programmer — supplied
v’ Cable -A DB9 “straight-thru” cable - supplied
v uPD78-Programmer PC software on CD-ROM - Optional Extra

The PC system requirements :

Desktop PC and a free Serial Communication Port (COML...8)
Memory - Minimum 32 Mbytes

Display - Color SVGA display recommended

Power supply 12 Volt/500 mA linear power supply source

OS -MS-Windows (Win98, Win2000/XP)
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3. INSTALLATION AND USE

The uPD78-Programmer includes two LED’s and mode jumper (Figure 1).
Color LED’s indicates programmer state and external power supply voltage (Table 1, 2).

GREEN uPD78-Programmer is ready.
GREEN Flashing | uPD78-Programmer is busy.
DARK Voltage applied to uPD78-Programmer lower than 6 Volt.

Table 1. LED D2 color meaning

GREEN | All signals on In-Circuit Programmer connector are active.

DARK Signals on In-Circuit Programmer connector are deactivated (in three state).

Table 2. LED D3 color meaning

Jumper-1 (JP1) is intended for uPD78-Programmer mode selection (see Table 3).

JP1 Shorted | Normal operation. NEC device EEPROM Reading/Programming.

JP1 Opened | Service mode. uPD78-Programmer firmware update.

Table 3. uPD78-Programmer operation modes

Programmer Firmware In-Circuit

Operation mode Update Programming
LED (D2) ‘ Jumper JP1 Connector

” -

¥
= O~ 1 [ ki
o : mn :
EL —_ 7 |HHE|B
E 2 HHE
- O
5)) QC) 13 2 14 I C t
c — n-Circui
°3 B O«Bus activity
~1 rn || |LED(D3)
R
External
Power Supply

Connector (9-12V)
Figure 1. The uPD78-Programmer board layout
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3.1 PROGRAMMER CHECK AND CONNECTION TO PC

(?

Connect the power supply source to uPD78-Programmer (an external 12 V DC power
supply source is required).

Attach a COM port cable to the 9-pin connector on the programmer and to a COM port
on the PC.

Insert jumper JP1 (see Figure 1).

Turn On power supply source and make sure that LED D1 appear green.

Start uPD78-Programmer software.

After few seconds you should see on display message: “uPD780973 Programmer Ver-
X.X detected”.

In case when you should see message: “uPD78 Dashboard Programmer Ver-X.X not
found”, change COM port number. To do that select “Tools” menu item and than select
“Comm Port Options”. Select new COM port number. After pressing “OK” button the
new setting will be applied and software reattempts connection with programmer.

Now uPD78-Programmer ready to operate.

Note: Update uPD78-Programmer firmware if required (see Section 3.2).

3.2 PROGRAMMER FIRMWARE UPDATE

This section describes how to update firmware (ATMEGA 16) of uPD78-Programmer.

©ETL 2004

Remove JP1 (see Figure 1).

Turn On power supply; make sure that LED D1 appears green.

Start uPD78-Programmer software.

Compare firmware version “uPD78 Dashboard Programmer Ver-X.X detected” and
version specified in “Help>About” menu item.

If versions not coincide, follow next steps to update firmware.

Select menu item “Tools>Firmware Update™.

After message box “Firmware Update” appeared, press “OK” button.

After firmware update completed, turn off power supply, close uPD78-Programmer
software.

Insert JP1.

Turn On power supply. Make sure that LED1 appear green.

Start uPD78-Programmer software on PC. New firmware version “uPD78 Dashboard
Programmer Ver-X.X detected” will appear.
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4. INTERFACE TYPES

This section describes In-Circuit Programming (ICP) interface, of uPD78-Programmer.

4.1 IN-CIRCUIT PROGRAMMING

In-Circuit programming interface is basic for uPD78-Programmer. With this interface uPD78-
Programmer automatically detects target MCU bus speed. Ceramic resonator connected to NEC
MCU must be in range from 4 MHz to 8.372 MHz. Signals required for communication with target
MCU described in Table 3.

PIN number Programmer Signal Description
1 Communication Pinl
2 Communication Pin2
3 Communication Pin3
4 Communication Pin4
5 Communication Pin5
6 Communication Pin6
7 Communication Pin7
8 Communication Pin8
9 IC Pin(Factory test mode)
10 Reset Pin
11 Communication Pin9
12 Communication Pin10
13 Built-in power supply +5V (Vcc).
14 Signal Ground (\Vdd)

Table 3. Pin functions of uPD78-Programmer ICP connector

©ETL 2004 uPD78 series Dashboard Programmer User’s Guide 6




5. WORKING WITH TARGET MCU

This section contains overall information about NEC78 MCUs supported by uPD78-
Programmer. When uPD78-Programmer successfully installed (see Section 3) target devices can
be read, program and verify.

5.1 In-Circuit EEPROM reading example

Connect required pins to board with target MCU (see Appendix).

Apply power to uPD78-Programmer. LED D2 became to green light (see Table 1).
Select corresponding device in uPD78-Programmer software (“Device” button).
Select “Read Sequence” panel in uPD78-Programmer software.

Press “EEPROM” button.

Press “Start” button.

LED D3 on uPD78-Programmer became to green light. That means that +5 voltage
regulator switched on and VCC applied to target MCU.

Now uPD78-Programmer automatically detects MCU bus speed.

When LED D2 on uPD78-Programmer became permanent green, reading completed.
Target MCU powered off.

After read sequence successfully completed it is necessarily to save memory dump to
file (see Section 6.2).

If some errors appeared during reading process refer to Section 7.

Connect required pins to board with target MCU (see Appendix).

Apply power to uPD78-Programmer. LED D2 became to green light (see Table 1).
Select corresponding device in uPD78-Programmer software (“Device” Button).
Load EEPROM data from file (see Section 6.1) or enter data to Hex Editor.

Select “Program Sequence” panel in uPD78-Programmer software.

Press “EEPROM” button.

Press “Start” button.

LED D3 on uPD78-Programmer became to green light. That means that +5 voltage
regulator switched on and VCC applied to target MCU.

Now uPD78-Programmer automatically detects MCU bus speed.

When LED D2 on uPD78-Programmer became permanent green, programming
completed. Target MCU powered off.

B If some errors appeared during programming process refer to Section 7.
e Note: Strongly recommended before EEPROM programming, for a first time,
read EEPROM contents and save it to file.
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5.3 Mileage Correction example

This section describes step by step operation with Honda Civic instrument cluster. All steps
must be done in order described below.
B Connect uPD78-Programmer board to PC using DB9 cable.
B Power-up the uPD78-Programmer. LED D2 (see Figurel) will light green.

?

Note: Jumper JP1 must be inserted see Table 3, uPD78-Programmer operation
modes.
B Start uPD78 Programmer software on PC. Next screen will appear:

@ uPD78 Dashboard Programmer ;IEIEI

File Edit Tools Window Help

=|H |3 @] =@ s f]E] o2 o]

[emo Mode

% Program Sequence | [ Read Sequence S5 Mileage Correction |
stimate Actual Mileage stimate Mew Mileage

IEIEIEIEIEIEI Fead | I Correction | Edit Dumg Wiew Infa

UPDYE Dashboard Programmer VER-1.0 detected |

[L ooy Wimctioa I 0%
Screenshot 1. uPD78 Programmer software after startup

?

Note: If message "uPD78 Dashboard Programmer not detected" appeared refer
to Section 3.1 for troubleshooting. If after changing the Communication port
number message "Programmer not detected" appeared restart the PC and try
again the procedure described in Section 3.1.

B Select Vehicle type from list. To do this press "Vehicle™ button (see Screenshot 1).

W If required vehicle selected, press "OK" button.

Select Device H

Huick Info

Yehicle: Honda Civic 2002 vear
MCU type: uPD 750973

EEPRODM: §0F900-50F9FF
Adapter: HNone

Programming Trterface:
In-Circuit: Ye=
On-Board: Mo

k. Cancel

"~ Screenshot 2. Vehicle type selection
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B After "Honda" selected the Graphic Information for connecting uPD78-Programmer to
dashboard is available. To see this information press "View Info" Button.

%' uPD78 Dashboard Programmer =10 x|

File Edit Tools Window Help
|28 =|E|S|¢] B e s FEE]o 2 ]
Yehicle | IHu:-nda Civic_2002_

% Program Sequence | [ Read Sequence 50 Mileage Correction |
stimate Actual Mileage stimate Mewe Mileage

IEIEIEIEIEIEI Fead | I Correction | Edit Dumg “iesw Info ||>

UPDYE Dazhboard Programmer VER-1 .0 detected |
Honda Civic_2002_ selected.

[Device Package Layvout ShowiClose || 0%
Screenshot 3. Find graphical wiring information.

B Solder pins from uPD78-Programmer to Honda dashboard.

(?

Note: The safe way to connect uPD78-Programmer to dashboard is to use
ribbon cable with 14 pin connector. After soldering completed connect it to
programmer. If wires directly connected to uPD78-Programmer, disconnect
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programmer from PC and external power supply during soldering. Also ESD
safe soldering iron must be used to avoid damaging of uPD78-Programmer and
dashboard.

B When wiring finished uPD78-Programmer ready to read estimate actual mileage. Press
"Read" button (see Screenshot 5).

%' uPD78 Dashboard Programmer =10 x|

Filz Edit

Tools  ‘Window Help

|28 =|E|S|¢] 2o s FEE] o2 ]
Yehicle | IHu:-nda Civic_2002_

[:} Programm Sequence | [3 Read Sequence o0 Mileage Carrection |

stimate Actual hilkesge
IEIEIEIEIEIEI Fead

stimate Mew Mileage

I Cotrection | Edit Dumg Wiewy Imfa

)

UPDYE Dashboard Programmer VER-1.0 detected |

Honda Civic_2002_ selected.

[Device Package Layvout ShowiClose || 0%

Screenshot 5. Start Actual mileage read

B Estimate actual mileage appeared in edit box located left from "Read" button (see
Screenshot 6).

?

E“ uPD7& Dashboard Programmer ;lglil

Fil=  Edit

Note: If during reading some errors like: "No Echo From Device" or "Pin Tester
Errors” appeared, refer for section 7-Errors and troubleshooting.

Tools  Window Help

aili=)

i =s(o| e o] = [0l

Yehicle | IHDnda Civic_2002_

% Program Sequence I [, Read Sequence 58 Mileage Correction |
pete Actual Mieage

=1ty _
fm:n 49 Read | I Correction | Edlit Crurmp Wiemwy Info |

=timate Mew Mileage

Honda Civic_2002_ selected. -
=

Linking Device ...
Eead Seouence in Procre

Auta Save to file : E'Program Filez'ETLWPDYS Dashboard ProgrammerDumps Temparary Directory'Honda Civi

Fead SeqUence completed succesatul ;l

[Estimate Mew Milsage I 0

?
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Screenshot 6. Actual mileage reading

Note: During reading uPD78-Programmer made a Backup copy of all EEPROM
contents. The Backup copy located in "Dumps Temporary Directory".
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Note: If after mileage reading message "Mileage Calculation Error: Wrong
EEPROM data" appeared, don't start mileage correction procedure. Possible
calculation algorithm not corresponds with algorithm used in instrument cluster.

B Mileage correction procedure similar to mileage read except for new estimate mileage
must be entered before operation (see Screenshot 7)
B After new mileage entered press "Correction™ button.

¥ uPD78 Dashboard Programmer -10| x|
File Edit Tools Window Help

HEls = as|e| =|e|sm e | = [
Yehicle | IHDnda Civic_2002_

[*% Program Sequence I [ Read Sequence G5 Mieage CDFFEETIDI'I

stimate Actual Mileage 1 imate e Milea
|4D1 43 Read | 1DUDDD| ( Correction | ) Edit Dump Wiey [mfo |

Mileage Carrection Seqguence in Progress . ;I

Auta Save to file : E'Program Filez'ETLWPDYS Dazhboard ProgrammerDumps Temparary Directory'Honds Civi—d

Mileage Carrection completed successful ;l
| | 0%

Screenshot 7. Mileage correction

?

Note: During mileage correction uPD78-Programmer made a Backup copy of
all EEPROM contents. The Backup copy located in "Dumps Temporary
Directory".
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6. FILE OPERATIONS

This section describes basic rules working with files. Memory dump from Hex Editor (Buffer)
can be load/save from/to hard disk. Also short descriptions such as project name, MCU type and
memory cell assignment can be done for future fast remind. uPD78-Programmer accepts tree types
of file formats:

v BIN (Binary format)

v Motorola S-Record (4 byte address)
v Motorola S-Record (6 byte address)
v EEF (Extended ETL Format)

6.1 LOAD FILE INTO BUFFER

Select “File>Open” menu item.
Press “Browse” button.
In File Open Dialog window, select file witch need to be open.
Press “Open” button.
Than opposite “Auto Format Detected:” text, select correct file format. Note that software
try automatically detects file format, but unknown records in file will fail this detection.
“Load Entire file” check box must be checked if automatically loading procedures
required.

B Than press “OK” button.

Sometimes load data from file to specific buffer allocations required. For Example if required
load buffer from $F900 address from binary file beginning from $0000 address follow next steps:
Select “File>Open” menu item.

Press “Browse” button.

In File Open Dialog window, select file which need to be open.

Press “Open” button.

Than, opposite “Auto Format Detected:” select Binary format.

Uncheck “Load Entire File” check box.

In field “Offset Value to Place Data to Buffer:” enter 0xF900.

Than press “OK” button.

Now data placed to Hex Editor Buffer from the beginning of 0x0400 address.

If more complicated operations with files required, for example load Hex Editor Buffer from
many files “Lowest Address From File To Load”, “Highest Address From File To Load” and
“Clear Buffer Before Loading File” options are available.

6.2 SAVE FILE FROM BUFFER

Select “File>Save” menu item.

Press “Browse” button.

Select directory in which file will be saved.
Type file name, for example “test1”

Press “Save” button.

Than select format in which file will be saved*.
Press “OK” button.

(?

Note: Use EEF Format for future “Load File Into Buffer” automatically
processing. Also, only in EEF Format Project Description, Device Name and
Memory Cells attributes can be saved.
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/. ERRORS AND TROUBLESHOOTING

This section describes most recently encountered problems, errors and fixing solutions.

M Problem: LED D1 (see Figure 1) Dark.

B Causes: This

problem can accrue when external power supply connected to uPD78-

Programmer is damaged or connected in wrong polarity.
M Solutions: Check voltage on uPD78-Programmer power clamps. It must be 9-12 V.

B Error Message:
B Causes:

W Solutions:

B Error Message:
B Causes:

W Solutions:

B Error Message:
W Causes:

W Solutions:
B Error Message:
W Causes:

B Solutions:

B Error Message:
B Causes:

M Solutions:

B Error Message:
B Causes:

W Solutions:

©ETL 2004

uPD780973 Programmer not found.

This message can appear when uPD78-Programmer software couldn’t
establish connection with uPD78-Programmer board.

Check connection of COM port cable from PC to uPD78-Programmer
board. Apply power from external power supply to uPD78-Programmer. In
menu item “Tools>Comm Port Options” select correct COM port number.

Communication Error.

This message can appear when Communication between uPD78-
Programmer and PC is broken.

Check COM port cable connection to board and PC. If message not
disappear restart the computer.

IC Pin must be in 'high’ state (line 9).

This message can appear when MCU IC pin connected to ground through
external components.

Cut any component from IC pin.

Reset Pin must be in 'high’ state (line 10).

This message can appear when MCU Reset pin connected to ground through
external components.

Cut any component and traces from Reset pin.

External Reset Occurred. Disconnect Reset pin (line 10) from external
circuit.

This message can appear when in time on reading/programming reset pulse
appeared on MCU Reset pin from external circuit.

Cut any component and traces from Reset pin.

Parallel Communication Lines (1-8) Setup Error.

This message can appear when communication lines 1-8 (see Table 3) pin
connected to ground or Vcc through external components.

Cut any component from pins.
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B Error Message:

W Causes:

W Solutions:

W Error Message:

B Causes:

W Solutions:

B Error Message:

W Causes:

W Solutions:

W Error Message:

B Causes:

B Solutions:

B Error Message:

B Causes:
W Solutions:

B Error Message:

B Causes:
B Solutions:

B Error Message:

B Causes:
B Solutions:

B Error Message:

B Causes:

W Solutions:

©ETL 2004

Pin Tester Errors.

This message can appear when NEC MCU pin(s) connected to ground or
Vcc through external components.

Cut any component from pin. To find out what pin must to be disconnected
refer to Table 3 and Appendix.

Echo Error.

This message can appear when programmer communication line 11
connected to ground or Vcc through external components. Or ceramic
resonator on NEC MCU has frequency instability.

Cut any component from pin. To find out what pin must to be disconnected
refer to Table 3 and Appendix. Or replace ceramic resonator connected to
NEC MCU.

No Echo From Device.

This message can appear when programmer lines connected in wrong way
with NEC MCU or wrong device selected in PC software.

Check lines connected to MCU and device selected in Device dialog on PC.
Try to reconnect by pressing "Start" Button

Target Device Speed too low.

This message can appear when ceramic resonator frequency connected to
NEC MCU is too low.

Replace ceramic resonator with frequency from 4-8 MHz.

Readout time-out Error.

This message can appear when NEC MCU do not respond long time.

Check lines connected to MCU and try to reconnect by pressing "Start”
Button

Transmitter time-out Error.

This message can appear when NEC MCU do not respond long time.

Check lines connected to MCU and try to reconnect by pressing "Start"
Button

Programming time-out Error.

This message can appear when NEC MCU do not respond long time.

Check lines connected to MCU and try to reconnect by pressing "Start"
Button

Programming Error.

This message can appear when programming of EEPROM completed with
errors.

Try to repeat programming sequence. If error still exists replace ceramic
resonator to 8MHz frequency.
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M Error Message: External Power Supply Error, Current Protection.

B Causes: This message can appear when current consumption from built-in power
supply grater than 250 mA.
M Solutions: Check target MCU power pins on short circuit.

B Error Message: WRONG SUBROUTINE CALL
WRONG DEVICE TYPE

W Causes: These messages can appear when fatal problems with UPD78-Programmer
hardware/firmware accrued.
W Solutions: Contact ETL technical support.
—a

Note: uPD78-Programmer has Log Window which can be stored to file. To
perform this operation right clicks on Log Window. Than click on “Save to
uPD78prog.log file* menu item. Now this file can be found in the same
directory as UPD78-Programmer software. Log File can be send by E-mail to
techsupport@etlweb.net for non described problem solution.

8. WARRANTY STATEMENT

ETL warrants that Product delivered shall conform to applicable. Report any defects for a 45
days period, from the applicable data on invoice.
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9. APPENDIX
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Figure 2. In-Circuit wiring diagram for uPD780973 MCU
e Note: In RED color denoted lines from UPD78-Programmer that must be
connected to target MCU.
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Figure 3. In-Circuit wiring diagram for uPD78(F)0948/49 MCU
—a

Note: In RED color denoted lines from UPD78-Programmer that must be
connected to target MCU.
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Figure 4. In-Circuit wiring diagram for uPD78(F)0828A MCU
e Note: In RED color denoted lines from UPD78-Programmer that must be
connected to target MCU.
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